Results 1 to 2 of 2

Thread: Aqua Clear 500 repair

  1. #1
    ECAS member

    Vervepipes's Avatar
    Join Date
    Jan 2017
    Location
    Cole Harbour, NS
    Posts
    187

    Aqua Clear 500 repair

    So my AC 500 on my Corydora tank has been very noisy, I got this filter with a bunch of other things I bought as a lot a few years ago. The impeller shaft is worn almost half way through and the impeller itself is suspect in the shaft hole. I bought a new impeller at 1 Fish 2 Fish today but forgot the shaft.

    I happen to have a bunch of Fluval 303s so I checked the shaft size and it's a match...ish. The ceramic shaft is the same width but longer, not an issue. The ends are not tapered however, so inserting it into the gromet which is stuck in the motor took some gentle pressing on a wooden block. End result is a now silent AC500. I have pictures of the progress but am having issues uploading from my phone, they will come.

  2. #2
    ECAS member

    Vervepipes's Avatar
    Join Date
    Jan 2017
    Location
    Cole Harbour, NS
    Posts
    187
    Here is a look at the worn shaft next to the 303 shaft. It looks worse in person, the wear is oblong.
    Click here to enlarge

    Fits like a glove.
    Click here to enlarge
    Had to press it in with a wood block
    Click here to enlarge

    Click here to enlarge

    Works like a charm.

    Click here to enlarge

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •